Back to overview
Degraded
Ethereum Dashboards are down
Apr 04 at 04:05am EDT
Affected services
Scale3 Web Backend
Resolved
Apr 04 at 05:46am EDT
We have identified the cause and the issue is now resolved.
Affected services
Scale3 Web Backend
Created
Apr 04 at 04:05am EDT
We are currently investigating an active issue with all the Ethereum(ETH) dashboards.
Affected services
Scale3 Web Backend